思科模拟器常用命令

计算机命令:

PCA login: root                                  :使用root用户

password: linux                                  :口令是linux

shutdown -h now                               :同init 0 关机

logout

login

ifconfig                                        :显示IP地址

ifconfig eth0 <ip address> netmask <netmask>    :设置IP地址

ifconfig eht0 <ip address> netmask <netmask> down : 删除IP地址

route add 0.0.0.0 gw <ip地址>

route del 0.0.0.0 gw <ip地址>

route add default gw <ip地址>                      :设置网关

route del default gw <ip地址>                      :删除网关

route                                            :显示网关

ping <ip地址>

telnet <ip地址>

PHP复制

交换机支持的命令:

交换机基本状态:

switch:                                            :交换机的ROM状态

rommon>                                            :路由器的ROM状态

hostname>                                        :用户模式

hostname#                                        :特权模式

hostname(config)#                               :全局配置模式

hostname(config-if)#                                :接口状态

PHP复制

交换机口令设置:

switch>enable                                      :进入特权模式

switch#config terminal                            :进入全局配置模式

switch(config)#hostname <hostname>                :设置交换机的主机名

switch(config)#enable secret xxx                    :设置特权加密口令

switch(config)#enable password xxa                :设置特权非密口令

switch(config)#line console 0                   :进入控制台口

switch(config-line)#line vty 0 4                    :进入虚拟终端

switch(config-line)#login                          :允许登录

switch(config-line)#password xx                    :设置登录口令xx

switch#exit                                     :返回命令

PHP复制

交换机VLAN设置:

switch#vlan database                                :进入VLAN设置

switch(vlan)#vlan 2                                :建VLAN 2

switch(vlan)#no vlan 2                            :删vlan 2

switch(config)#int f0/1                         :进入端口1

switch(config-if)#switchport access vlan 2       :当前端口加入vlan 2

switch(config-if)#switchport mode trunk          :设置为干线

switch(config-if)#switchport trunk allowed vlan 1,2 :设置允许的vlan

switch(config-if)#switchport trunk encap dot1q    :设置vlan 中继

switch(config)#vtp domain <name>                    :设置发vtp域名

switch(config)#vtp password <word>                :设置发vtp密码

switch(config)#vtp mode server                   :设置发vtp模式

switch(config)#vtp mode client                   :设置发vtp模式

PHP复制

交换机设置IP地址:

switch(config)#interface vlan 1                    :进入vlan 1

switch(config-if)#ip address <IP> <mask>          :设置IP地址

switch(config)#ip default-gateway <IP>              :设置默认网关

switch#dir flash:                               :查看闪存

PHP复制

交换机显示命令:

switch#write                                     :保存配置信息

switch#show vtp                                  :查看vtp配置信息

switch#show run                                  :查看当前配置信息

switch#show vlan                                  :查看vlan配置信息

switch#show interface                            :查看端口信息

switch#show int f0/0                                :查看指定端口信息

PHP复制

路由器显示命令:

router#show run                                  :显示配置信息

router#show interface                            :显示接口信息

router#show ip route                                :显示路由信息

router#show cdp nei                                :显示邻居信息

router#reload                                   :重新起动

PHP复制

路由器口令设置:

router>enable                                      :进入特权模式

router#config terminal                            :进入全局配置模式

router(config)#hostname <hostname>                :设置交换机的主机名

router(config)#enable secret xxx                    :设置特权加密口令

router(config)#enable password xxb                :设置特权非密口令

router(config)#line console 0                   :进入控制台口

router(config-line)#line vty 0 4                    :进入虚拟终端

router(config-line)#login                          :要求口令验证

router(config-line)#password xx                    :设置登录口令xx

router(config)#(Ctrl+z)                         : 返回特权模式

router#exit                                     :返回命令

PHP复制

路由器配置:

router(config)#int s0/0                         :进入Serail接口

router(config-if)#no shutdown                   :激活当前接口

router(config-if)#clock rate 64000                :设置时钟频率

router(config-if)#ip address <ip地址> <netmask>        :设置IP地址

router(config-if)#ip address <ip地址> <netmask> second   :设置第二个IP

router(config-if)#int f0/0.1                      :进入子接口

router(config-subif.1)#ip address <ip地址> <netmask> :设置子接口IP

router(config-subif.1)#encapsulation dot1q <n>    :绑定vlan中继协议

router(config)#config-register 0x2142              :跳过配置文件

router(config)#config-register 0x2102              :正常使用配置文件

router#reload                                      :重新引导

PHP复制

路由器文件操作:

router#copy running-config startup-config       :保存配置

router#copy running-config tftp                    :保存配置到tftp

router#copy startup-config tftp                    :开机配置存到tftp

router#copy tftp flash:                         :下传文件到flash

router#copy tftp startup-config                    :下载配置文件

PHP复制

ROM状态:

Ctrl+Break                                        :进入ROM监控状态

rommon>confreg 0x2142                            :跳过配置文件

rommon>confreg 0x2102                            :恢复配置文件

rommon>reset                                     :重新引导

rommon>copy xmodem:<sname> flash:<dname>          :从console传输文件

 

rommon>IP_ADDRESS=10.65.1.2                      :设置路由器IP

rommon>IP_SUBNET_MASK=255.255.0.0                :设置路由器掩码

rommon>TFTP_SERVER=10.65.1.1                      :指定TFTP服务器IP

rommon>TFTP_FILE=c2600.bin                          :指定下载的文件

rommon>tftpdnld                                  :从tftp下载

rommon>dir flash:                               :查看闪存内容

rommon>boot                                     :引导IOS

PHP复制

静态路由:

ip route <ip-address> <subnet-mask> <gateway>    :命令格式

router(config)#ip route 2.0.0.0 255.0.0.0 1.1.1.2   :静态路由举例

router(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.2 :默认路由举例

PHP复制

动态路由:

router(config)#ip routing                          :启动路由转发

router(config)#router rip                          :启动RIP路由协议。

router(config-router)#network <netid>              :设置发布路由

router(config-router)#negihbor <ip地址>             :点对点帧中继用。

PHP复制

帧中继命令:

router(config)#frame-relay switching             :使能帧中继交换

router(config-s0)#encapsulation frame-relay        :使能帧中继

router(config-s0)#fram-relay lmi-type cisco        :设置管理类型

router(config-s0)#frame-relay intf-type DCE        :设置为DCE

router(config-s0)#frame-relay dlci 16              :

router(config-s0)#frame-relay local-dlci 20        :设置虚电路号

router(config-s0)#frame-relay interface-dlci 16 :

router(config)#log-adjacency-changes             :记录邻接变化

router(config)#int s0/0.1 point-to-point          :设置子接口点对点

router#show frame pvc                            :显示永久虚电路

router#show frame map                            :显示映射

PHP复制

基本访问控制列表:

router(config)#access-list <number> permit|deny <source_ip> <wild|any>

router(config)#interface <interface>             :default:deny any

router(config-if)#ip access-group <number> in|out   :defaultut

PHP复制

例1:

router(config)#access-list 1 deny host 10.65.1.1

router(config)#access-list 1 permit any

router(config)#int f0/0

router(config-if)#ip access-group 4 in

PHP复制

例2:

router(config)#access-list 4 permit 10.8.1.1

router(config)#access-list 4 deny 10.8.1.0 0.0.0.255

router(config)#access-list 4 permit 10.8.0.0 0.0.255.255

router(config)#access-list 4 deny 10.0.0.0 0.255.255.255

router(config)#access-list 4 permit any

router(config)#int f0/1

router(config-if)#ip access-group 4 in

PHP复制

扩展访问控制列表:

access-list <number> permit|deny icmp <S_IP wild> <D_IP wild>[type]

access-list <number> permit|deny tcp <S_IP wild> <D_IP wild>[port]

PHP复制

例1:

router(config)#access-list 101 deny icmp any 10.64.0.2 0.0.0.0 echo

router(config)#access-list 101 permit ip any any

router(config)#int s0/0

router(config-if)#ip access-group 101 in

PHP复制

例2:

router(config)#access-list 102 deny tcp any 10.65.0.2 0.0.0.0 eq 80

router(config)#access-list 102 permit ip any any

router(config)#interface s0/1

router(config-if)#ip access-group 102 out

PHP复制

删除访问控制例表:

router(config)#no access-list 102

router(config-if)#no ip access-group 101 in

PHP复制

路由器的nat配置

Router(config-if)#ip nat inside              :当前接口指定为内部接口

Router(config-if)#ip nat outside              :当前接口指定为外部接口

Router(config)#ip nat inside source static [p] <私有IP><公网IP> [port]

Router(config)#ip nat inside source static 10.65.1.2 60.1.1.1

Router(config)#ip nat inside source static tcp 10.65.1.3 80 60.1.1.1 80

Router(config)#ip nat pool p1 60.1.1.1 60.1.1.20 255.255.255.0

Router(config)#ip nat inside source list 1 pool p1

Router(config)#ip nat inside destination list 2 pool p2

Router(config)#ip nat inside source list 2 interface s0/0 overload

Router(config)#ip nat pool p2 10.65.1.2 10.65.1.4 255.255.255.0 type rotary

Router#show ip nat translation

rotary 参数是轮流的意思,地址池中的IP轮流与NAT分配的地址匹配。

overload参数用于PAT 将内部IP映射到一个公网IP不同的端口上。

PHP复制

外部网关协议配置

routerA(config)#router bgp 100

routerA(config-router)#network 19.0.0.0

routerA(config-router)#neighbor 8.1.1.2 remote-as 200

PHP复制

配置PPP验证:

RouterA(config)#username <RouterB> password <word>

RouterA(config)#int s0

RouterA(config-if)#ppp authentication {chap|pap}

PHP复制

PIX防火墙命令

Pix525(config)#nameif ethernet0 outside security0    :命名接口和级别

Pix525(config)#interface ethernet0 auto             :设置接口方式

Pix525(config)#interface ethernet1 100full              :设置接口方式

Pix525(config)#interface ethernet1 100full shutdown

Pix525(config)#ip address inside 192.168.0.1 255.255.255.0

Pix525(config)#ip address outside 133.0.0.1 255.255.255.252

 

Pix525(config)#global (if_name) natid ip-ip          :定义公网IP区间

Pix525(config)#global (outside) 1 7.0.0.1-7.0.0.15    :例句

Pix525(config)#global (outside) 1 133.0.0.1          :例句

Pix525(config)#no global (outside) 1 133.0.0.1       :去掉设置

 

Pix525(config)#nat (if_name) nat_id local_ip [netmark]

Pix525(config)#nat (inside) 1 0 0

内网所有主机(0代表0.0.0.0)可以访问global 1指定的外网。

Pix525(config)#nat (inside) 1 172.16.5.0 255.255.0.0

内网172.16.5.0/16网段的主机可以访问global 1指定的外网。

 

Pix525(config)#route if_name 0 0 gateway_ip [metric]        :命令格式

Pix525(config)#route outside 0 0 133.0.0.1 1             :例句

Pix525(config)#route inside 10.1.0.0 255.255.0.0 10.8.0.1 1 :例句

 

Pix525(config)#static (inside, outside) 133.0.0.1 192.168.0.8

表示内部ip地址192.168.0.8,访问外部时被翻译成133.0.0.1全局地址。

 

Pix525(config)#static (dmz, outside) 133.0.0.1 172.16.0.8

中间区域ip地址172.16.0.8,访问外部时被翻译成133.0.0.1全局地址。

PHP复制

switch配置命令

模式转换命令

用户模式—-特权模式,使用命令”enable”

特权模式—-全局配置模式,使用命令”config t”

全局配置模式—-接口模式,使用命令”interface+接口类型+接口号”

全局配置模式—-线控模式,使用命令”line+接口类型+接口号”

注:

用户模式:查看初始化的信息.

特权模式:查看所有信息、调试、保存配置信息

全局模式:配置所有信息、针对整个路由器或交换机的所有接口

接口模式:针对某一个接口的配置

线控模式:对路由器进行控制的接口配置

配置命令

show running config 显示所有的配置

show versin 显示版本号和寄存器值

shut down 关闭接口

no shutdown 打开接口

ip add +ip地址 配置IP地址

secondary+IP地址 为接口配置第二个IP地址

show interface+接口类型+接口号 查看接口管理性

show controllers interface 查看接口是否有DCE电缆

show history 查看历史记录

show terminal 查看终端记录大小

hostname+主机名 配置路由器或交换机的标识

config memory 修改保存在NVRAM中的启动配置

exec timeout 0 0 设置控制台会话超时为0

service password-encryptin 手工加密所有密码

enable password +密码 配置明文密码

ena sec +密码 配置密文密码

line vty 0 4/15 进入telnet接口

password +密码 配置telnet密码

line aux 0 进入AUX接口

password +密码 配置密码

line con 0 进入CON接口

password +密码 配置密码

bandwidth+数字 配置带宽

no ip address 删除已配置的IP地址

show startup config 查看NVRAM中的配置信息

copy run-config startup config 保存信息到NVRAM

write 保存信息到NVRAM

erase startup-config 清除NVRAM中的配置信息

show ip interface brief 查看接口的谪要信息

banner motd # +信息 + # 配置路由器或交换机的描素信息

description+信息 配置接口听描素信息

vlan database 进入VLAN数据库模式

vlan +vlan号+ 名称 创建VLAN

switchport access vlan +vlan号 为VLAN为配接口

interface vlan +vlan号 进入VLAN接口模式

ip add +ip地址 为VLAN配置管理IP地址

vtp+service/tracsparent/client 配置SW的VTP工作模式

vtp +domain+域名 配置SW的VTP域名

vtp +password +密码 配置SW的密码

switchport mode trunk 启用中继

no vlan +vlan号 删除VLAN

show spamming-tree vlan +vlan号 查看VLA怕生成树议

PHP复制

路由器配置命令

ip route+非直连网段+子网掩码+下一跳地址 配置静态/默认路由

show ip route 查看路由表

show protocols 显示出所有的被动路由协议和接口上哪些协议被设置

show ip protocols 显示了被配置在路由器上的路由选择协议,同时给出了在路由选择协议中使用的定时器等信息

router rip 激活RIP协议

network +直连网段 发布直连网段

interface lookback 0 激活逻辑接口

passive-interface +接口类型+接口号 配置接口为被动模式

debug ip +协议 动态查看路由更新信息

undebug all 关闭所有DEBUG信息

router eigrp +as号 激活EIGRP路由协议

network +网段+子网掩码 发布直连网段

show ip eigrp neighbors 查看邻居表

show ip eigrp topology 查看拓扑表

show ip eigrp traffic 查看发送包数量

router ospf +process-ID 激活OSPF协议

network+直连网段+area+区域号 发布直连网段

show ip ospf 显示OSPF的进程号和ROUTER-ID

encapsulation+封装格式 更改封装格式

no ip admain-lookup 关闭路由器的域名查找

ip routing 在三层交换机上启用路由功能

show user 查看SW的在线用户

clear line +线路号 清除线路

PHP复制

三层交换机配置命令

配置一组二层端口

configure terminal 进入配置状态

nterface range {port-range} 进入组配置状态

配置三层端口

configure terminal 进入配置状态

interface {{fastethernet | gigabitethernet} interface-id} | {vlan vlan-id} | {port-

channel port-channel-number} 进入端口配置状态

no switchport 把物理端口变成三层口

ip address ip_address subnet_mask 配置IP地址和掩码

no shutdown 激活端口

PHP复制

例:

Switch(config)# interface gigabitethernet0/2

Switch(config-if)# no switchport

Switch(config-if)# ip address 192.20.135.21 255.255.255.0

Switch(config-if)# no shutdown

PHP复制

配置VLAN

configure terminal 进入配置状态

vlan vlan-id 输入一个VLAN号, 然后进入vlan配态,可以输入一个新的VLAN号或旧的来进行修改



name vlan-name 可选)输入一个VLAN名,如果没有配置VLAN名,缺省的名字是VLAN号前面用0填满的4位数,如VLAN0004是VLAN4的缺省名字

mtu mtu-size (可选) 改变MTU大小

PHP复制

Switch# configure terminal

Switch(config)# vlan 20

Switch(config-vlan)# name test20

Switch(config-vlan)# end

或

Switch# vlan database

Switch(vlan)# vlan 20 name test20

Switch(vlan)# exit

PHP复制

将端口分配给一个VLAN

configure terminal 进入配置状态

interface interface-id 进入要分配的端口

switchport mode access 定义二层口

switchport access vlan vlan-id 把端口分配给某一VLAN

PHP复制

 例

Switch# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)# interface fastethernet0/1

Switch(config-if)# switchport mode access

Switch(config-if)# switchport access vlan 2

Switch(config-if)# end

Switch#

PHP复制

配置VLAN trunk

configure terminal 进入配置状态

interface interface-Id 进入端口配置状态

switchport trunk encapsulation {isl | dot1q | negotiate}配置trunk封装ISL 或 802.1Q 或

自动协商

switchport mode {dynamic {auto | desirable} | trunk} 配置二层trunk模式。

dynamic auto—自动协商是否成为trunk

dynamic desirable—把端口设置为trunk如果对方端口是trunk, desirable, 配置Native VLAN

(802.1q)

或自动模式,trunk—设置端口为强制的trunk方式,而不理会对方端口是否为trunk

switchport access vlan vlan-id 可选) 指定一个缺省VLAN, 如果此端口不再是trunk

switchport trunk native vlan vlan-id 指定802.1Q native VLAN号

PHP复制

 例:

Switch# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)# interface fastethernet0/4

Switch(config-if)# switchport mode trunk

Switch(config-if)# switchport trunk encapsulation dot1q

Switch(config-if)# end

PHP复制

定义TRUNK允许的VLAN

configure terminal子 进入配置状态

interface interface-id 进入端口配置

switchport mode trunk 配置二层口为trunk

switchport trunk allowed vlan {add | all | except | remove} vlan-list可选) 配置trunk允

许的VLAN.使用add, all, except, remove关健字

no switchport trunk allowed vlan 允许所有VLAN通过

PHP复制

 例

Switch(config)# interface fastethernet0/1

Switch(config-if)# switchport trunk allowed vlan remove 2

Switch(config-if)# end

PHP复制

配置Native VLAN(802.1q)

configure terminal 进入配置状态

interface interface-id 进入配置成802.1qtrunk的端口

switchport trunk native vlan vlan-Id 配置native VLAN号

no switchport trunk native vlan 端口配置命令回到缺省的状态

配置基于端口权值的负载均衡

configure terminal 进入Switch 1配置状态

vtp domain domain-name 配置VTP域

vtp mode server 将Switch 1配置成VTP server.

show vtp status 验证VTP的配置

show vlan 验证VLAN

configure terminal 进入配置状态

interface fastethernet 0/1 进入F0/1端口

switchport trunk encapsulation {isl | dot1q | negotiate}配置trunk封装

switchport mode trunk 配置成trunk

show interfaces fastethernet0/1 switchport 验证VLAN配置

按以上步骤对想要负载均衡的接口进行配置

在另一个交换机上进行此配置

show vlan 当trunk已经起来,在switch2上验证已经学到相的vlan配置

configure terminal 在Switch 1上进入配置状态

interface fastethernet0/1 进入要配置的端口

spanning-tree vlan 8 port-priority 10 将端口权值10赋与VLAN 8.

spanning-tree vlan 9 port-priority 10 将端口权值10赋与VLAN 9.

spanning-tree vlan 10 port-priority 10 将端口权值10赋与VLAN 10.

interface fastethernet0/2 进入F0/2

spanning-tree vlan 3 port-priority 10 将端口权值10赋与VLAN 3.

spanning-tree vlan 4 port-priority 10 将端口权值10赋与VLAN 4

spanning-tree vlan 5 port-priority 10 将端口权值10赋与VLAN 5

spanning-tree vlan 6 port-priority 10 将端口权值10赋与VLAN 10

end 退出

show running-config 验证配置

copy running-config startup-config 保存配置

配置STP路径值的负载均衡

Trunk1走VLAN8-10,Trunk2走VLAN2-4

configure terminal 进入 Switch 1配置状态

interface fastethernet 0/1 进入F0/1

switchport trunk encapsulation {isl | dot1q | negotiate}配置封装

switchport mode trunk 配置Trunk,缺省是ISL封装

exit 退回

在F0/2口上重复2-4步骤

exit 退回

show running-config 验证配置

show vlan验证switch1 已经学到Vlan

configure terminal 进入配置状态

interface fastethernet 0/1 进入F0/1

spanning-tree vlan 2 cost 30 设置Vlan2生成树路径值为30

spanning-tree vlan 3 cost 30 设置Vlan3生成树路径值为30

spanning-tree vlan 4 cost 30 设置Vlan4生成树路径值为30

end 退出

在switch1的F0/2上重复9-11步骤设置VLAN8,9,10生成树路径值为30

end 退出

show running-config 验证配置

copy running-config startup-config 保存配置

补充:CISCO命令集——路由选择协议及排障

PHP复制

ip route命令


Router(config)# ip route <目录网络或子网号> [子网掩码] <下一路由器IP地址 | 从本地出口的地址> [管理距离0~255,默认为1]

     (注:静态地址配置)

PHP复制

ip default-network命令

Router(config)# ip default-network <目标网络号>

     (注:配合路由协使用,用其中的一个动态路由号作默认路由配置)

Router(config)# ip route 0.0.0.0 0.0.0.0 <下一路由器IP地址 | 从本地出口的地址>

     (注:只有一个公网地址时,在出口路由器上的配置)

PHP复制

内部路由选择协议

使用router和network命令

Router(config)# router <路由协议rip | igrp | eigrp | ospf | is-is等> [自主系统号]

Router(config-router)# network <直接相连的要用此路由协议的网络号>

Router(config-router)# network <直接相连的要用此路由协议的网络号>

PHP复制

路由信息协议RIP

Router(config)# router rip

Router(config-router)# network <直接相连的要用rip协议的有类别网络号>

Router# show ip protocols

Router# show ip route

Router# debug ip rip

PHP复制

内部网关路由协议IGRP

Router(config)# router igrp <自主系统号>

Router(config-router)# network <直接相连的要用igrp协议的有类别网络号>

Router# show ip interface

Router# show ip protocols

Router# show ip route

Router# debug ip rip

PHP复制

排除网络故障

排除网络故障的一个总体模型

Router# ping <有故障的主机 | 有故障的IP地址>

Router# show ip route

Router# show interface <有故障的接口>

Router# show run

PHP复制

IP的故故障排除

检查可用的路由

Router# show ip route <有故障的IP地址>

PHP复制

跟踪路由(Tracing the Route)

SUN-A> traceroute <有故障的主机 | 有故障的IP地址>

C:\windows\> winipcfg

C:\windows\> ipconfig

C:\windows\> ipconfig / all

C:\windows\> tracert <有故障的主机 | 有故障的IP地址>

PHP复制

使用扩展的ping来跟踪连接性

Router# ping

PHP复制

其它可能的故障

一个地址解析(ARP)的故障

Router# show arp

Router# show interface <有故障的接口>

C:\windows\> arp -a

SUN-A> arp –a

PHP复制

验证终端系统的路由表

C:\windows\> netstat –rn

C:\windows\> route –f add 0.0.0.0 mask 0.0.0.0 <需要添加入的网关地址>

C:\windows\> route [–f ] [[print | add | delete | change] [destination] [masknetmask] [gateway]]

C:\windows\> route add mask <网络掩码> <网关ip地址>

C:\windows\> route delete mask <网络掩码> <网关ip地址>

C:\windows\> nbtstat <相应的参数>

SUN-A> netstat -rn路由器

PHP复制

温馨提示: 本文最后更新于2022-03-10 19:13:54,某些文章具有时效性,若有错误或已失效,请在下方 留言或联系 购印资源网
© 版权声明
THE END
喜欢就支持一下吧
评论 抢沙发

请登录后发表评论

    暂无评论内容